Plugin security / WPForms Lite
WPForms Lite vulnerability: is your WooCommerce store affected?
WPForms Lite has 2 serious security holes rated 7 or higher out of 10 that someone can use with no login or with only a customer account. The newest was published on 28 May 2026. Every one is fixed: update to 1.10.0.5 or newer.
Short answer: your store is affected if it runs WPForms Lite older than 1.10.0.5. Update to 1.10.0.5 or newer, on a copy of the store first if you can.
In our check of 3,600 live UK and US WooCommerce stores (31 October 2026 to 1 November 2026), 25 were running a version of WPForms Lite with a serious hole that already had a fix. How we checked.
The security holes
Newest first. Each one is published in a public security database and fixed in the version shown.
Missing permission check
An action that should need permission could be done without it.
Score 7.5 (high)no login neededAffected: older than 1.10.0.5Fixed in 1.10.0.5Published 28 May 2026CVE-2026-48835
Advisory: Unauthenticated Broken Access Control in Contact Form by WPForms <= 1.10.0.4 versions.
Cross-site request forgery
Someone could trick a logged-in admin into making a change.
Score 8.1 (high)no login neededAffected: older than 1.10.0.3Fixed in 1.10.0.3Published 31 March 2026CVE-2026-40764
Advisory: Cross-Site Request Forgery (CSRF) vulnerability in Syed Balkhi Contact Form by WPForms wpforms-lite allows Cross Site Request Forgery.This issue affects Contact Form by WPForms: from n/a through <= 1.10.0.2.
How to check your version
- Log in to WordPress and open
Plugins > Installed Plugins. - Find WPForms Lite. The version number is under its name. If it is lower than 1.10.0.5, your store is affected.
- No login to hand? Open
https://yourstore.com/wp-content/plugins/wpforms-lite/readme.txtin a browser, with your own address in place of yourstore.com, and read theStable tagline. Some hosts block this file; then use step 1.
How to fix it
- Make a backup, or better, a staging copy of the store (most hosts have a one-click staging button).
- On the copy, update WPForms Lite to 1.10.0.5 or newer:
Dashboard > Updates, orUpdate nowon the Plugins page. - If no update shows, it may be a paid version whose licence has run out: download the new version from the seller's site and upload it.
- Place a test order on the copy: add to cart, check out, pay with a test method. Check the pages that use WPForms Lite.
- If everything works, make the same update on the live store and place one more test order.
- If you no longer use WPForms Lite, delete it instead of leaving it deactivated.
Not sure, or no time?
Get a free check of your store: we look at its public pages for plugins with known holes, and reply within one working day. Or we fix it for you: we update your store on a copy, place a test order, and only then change the live store, for a fixed £99 / $119.
Free store check Fix it for me on a copyQuestions
- Which WPForms Lite version fixes it?
- Version 1.10.0.5 or newer fixes all 2 issues on this page.
- How do I know if my store is affected?
- Your store is affected if it runs WPForms Lite older than 1.10.0.5. In WordPress, open Plugins and read the version under WPForms Lite. Without logging in, open yourstore.com/wp-content/plugins/wpforms-lite/readme.txt and read the Stable tag line.
- I don't use WPForms Lite any more. Is a deactivated copy safe?
- Deactivating it lowers the risk but leaves the old code on your server. If you don't use it, delete it; if you do, update it.
- Can someone fix it for me?
- Yes. We update the store on a copy first, place a test order, and only then make the same change on the live store, for a fixed price.
Vulnerability data: WPVulnerability (wpvulnerability.net, CC0), which links each entry to its CVE or advisory. Store numbers: Tadrik's own checks of public pages, aggregates only. Page updated 3 November 2026.