Plugin security / WooCommerce Square
WooCommerce Square vulnerability: is your WooCommerce store affected?
WooCommerce Square has 2 serious security holes rated 7 or higher out of 10 that someone can use with no login or with only a customer account. The newest was published on 9 January 2026. Every one is fixed: update to 5.1.2 or newer.
Short answer: your store is affected if it runs WooCommerce Square older than 5.1.2. Update to 5.1.2 or newer, on a copy of the store first if you can.
In our check of 3,600 live UK and US WooCommerce stores (31 October 2026 to 1 November 2026), 8 were running a version of WooCommerce Square with a serious hole that already had a fix. How we checked.
The security holes
Newest first. Each one is published in a public security database and fixed in the version shown.
Missing permission check
An action that should need permission could be done without it.
Score 7.5 (high)no login neededAffected: 4.2.0 up to, not including, 5.1.2Fixed in 5.1.2Published 9 January 2026CVE-2025-13457
Advisory: The WooCommerce Square plugin for WordPress is vulnerable to Insecure Direct Object Reference in all versions up to, and including, 5.1.1 via the get_token_by_id function due to missing validation on a user...
Missing permission check
An action that should need permission could be done without it.
Score 8.1 (high)needs only a customer accountAffected: older than 3.8.2Fixed in 3.8.2Published 19 June 2023CVE-2023-35876
Advisory: Authorization Bypass Through User-Controlled Key vulnerability in WooCommerce WooCommerce Square.This issue affects WooCommerce Square: from n/a through 3.8.1.
How to check your version
- Log in to WordPress and open
Plugins > Installed Plugins. - Find WooCommerce Square. The version number is under its name. If it is lower than 5.1.2, your store is affected.
- No login to hand? Open
https://yourstore.com/wp-content/plugins/woocommerce-square/readme.txtin a browser, with your own address in place of yourstore.com, and read theStable tagline. Some hosts block this file; then use step 1.
How to fix it
- Make a backup, or better, a staging copy of the store (most hosts have a one-click staging button).
- On the copy, update WooCommerce Square to 5.1.2 or newer:
Dashboard > Updates, orUpdate nowon the Plugins page. - If no update shows, it may be a paid version whose licence has run out: download the new version from the seller's site and upload it.
- Place a test order on the copy: add to cart, check out, pay with a test method. Check the pages that use WooCommerce Square.
- If everything works, make the same update on the live store and place one more test order.
- If you no longer use WooCommerce Square, delete it instead of leaving it deactivated.
Not sure, or no time?
Get a free check of your store: we look at its public pages for plugins with known holes, and reply within one working day. Or we fix it for you: we update your store on a copy, place a test order, and only then change the live store, for a fixed £99 / $119.
Free store check Fix it for me on a copyQuestions
- Which WooCommerce Square version fixes it?
- Version 5.1.2 or newer fixes all 2 issues on this page.
- How do I know if my store is affected?
- Your store is affected if it runs WooCommerce Square older than 5.1.2. In WordPress, open Plugins and read the version under WooCommerce Square. Without logging in, open yourstore.com/wp-content/plugins/woocommerce-square/readme.txt and read the Stable tag line.
- I don't use WooCommerce Square any more. Is a deactivated copy safe?
- Deactivating it lowers the risk but leaves the old code on your server. If you don't use it, delete it; if you do, update it.
- Can someone fix it for me?
- Yes. We update the store on a copy first, place a test order, and only then make the same change on the live store, for a fixed price.
Vulnerability data: WPVulnerability (wpvulnerability.net, CC0), which links each entry to its CVE or advisory. Store numbers: Tadrik's own checks of public pages, aggregates only. Page updated 3 November 2026.