Plugin security / Popup Maker
Popup Maker vulnerability: is your WooCommerce store affected?
Popup Maker has 4 serious security holes rated 7 or higher out of 10 that someone can use with no login or with only a customer account. The newest was published on 17 September 2026. Every one is fixed: update to 1.25.0 or newer.
Short answer: your store is affected if it runs Popup Maker older than 1.25.0. Update to 1.25.0 or newer, on a copy of the store first if you can.
In our check of 3,600 live UK and US WooCommerce stores (31 October 2026 to 1 November 2026), 18 were running a version of Popup Maker with a serious hole that already had a fix. How we checked.
The security holes
Newest first. Each one is published in a public security database and fixed in the version shown.
Cross-site scripting
Someone could plant a script that runs in your visitors' or your admins' browsers.
Score 7.2 (high)no login neededAffected: older than 1.25.0Fixed in 1.25.0Published 17 September 2026CVE-2026-87915
Advisory: The Popup Maker – Boost Sales, Conversions, Optins, Subscribers with the Ultimate WP Popup Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via values[Name] Parameter in all versions up to,...
Cross-site scripting
Someone could plant a script that runs in your visitors' or your admins' browsers.
Score 7.1 (high)no login neededAffected: older than 1.24.0Fixed in 1.24.0Published 5 August 2026CVE-2026-28177
Advisory: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Code Atlantic LLC Popup Maker popup-maker allows DOM-Based XSS.This issue affects Popup Maker: from n/a through...
Cross-site scripting
Someone could plant a script that runs in your visitors' or your admins' browsers.
Score 7.1 (high)no login neededAffected: older than 1.10.0Fixed in 1.10.0Published 19 July 2023c1fb5dd9342f13923ddf9b187876b8b3cb7dea4c
1 older hole, published before 1 January 2023
Missing permission check
An action that should need permission could be done without it.
Score 9.1 (critical)no login neededAffected: older than 1.8.13Fixed in 1.8.13Published 14 October 2019CVE-2019-17574
Advisory: An issue was discovered in the Popup Maker plugin before 1.8.13 for WordPress.
How to check your version
- Log in to WordPress and open
Plugins > Installed Plugins. - Find Popup Maker. The version number is under its name. If it is lower than 1.25.0, your store is affected.
- No login to hand? Open
https://yourstore.com/wp-content/plugins/popup-maker/readme.txtin a browser, with your own address in place of yourstore.com, and read theStable tagline. Some hosts block this file; then use step 1.
How to fix it
- Make a backup, or better, a staging copy of the store (most hosts have a one-click staging button).
- On the copy, update Popup Maker to 1.25.0 or newer:
Dashboard > Updates, orUpdate nowon the Plugins page. - If no update shows, it may be a paid version whose licence has run out: download the new version from the seller's site and upload it.
- Place a test order on the copy: add to cart, check out, pay with a test method. Check the pages that use Popup Maker.
- If everything works, make the same update on the live store and place one more test order.
- If you no longer use Popup Maker, delete it instead of leaving it deactivated.
Not sure, or no time?
Get a free check of your store: we look at its public pages for plugins with known holes, and reply within one working day. Or we fix it for you: we update your store on a copy, place a test order, and only then change the live store, for a fixed £99 / $119.
Free store check Fix it for me on a copyQuestions
- Which Popup Maker version fixes it?
- Version 1.25.0 or newer fixes all 4 issues on this page.
- How do I know if my store is affected?
- Your store is affected if it runs Popup Maker older than 1.25.0. In WordPress, open Plugins and read the version under Popup Maker. Without logging in, open yourstore.com/wp-content/plugins/popup-maker/readme.txt and read the Stable tag line.
- I don't use Popup Maker any more. Is a deactivated copy safe?
- Deactivating it lowers the risk but leaves the old code on your server. If you don't use it, delete it; if you do, update it.
- Can someone fix it for me?
- Yes. We update the store on a copy first, place a test order, and only then make the same change on the live store, for a fixed price.
Vulnerability data: WPVulnerability (wpvulnerability.net, CC0), which links each entry to its CVE or advisory. Store numbers: Tadrik's own checks of public pages, aggregates only. Page updated 3 November 2026.