Plugin security / PixelYourSite
PixelYourSite vulnerability: is your WooCommerce store affected?
PixelYourSite has 2 serious security holes rated 7 or higher out of 10 that someone can use with no login or with only a customer account. The newest was published on 20 February 2026. Every one is fixed: update to 11.2.0.2 or newer.
Short answer: your store is affected if it runs PixelYourSite older than 11.2.0.2. Update to 11.2.0.2 or newer, on a copy of the store first if you can.
In our check of 3,600 live UK and US WooCommerce stores (31 October 2026 to 1 November 2026), 9 were running a version of PixelYourSite with a serious hole that already had a fix. How we checked.
The security holes
Newest first. Each one is published in a public security database and fixed in the version shown.
Cross-site scripting
Someone could plant a script that runs in your visitors' or your admins' browsers.
Score 7.1 (high)no login neededAffected: older than 11.2.0.2Fixed in 11.2.0.2Published 20 February 2026CVE-2026-27072
Advisory: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in PixelYourSite PixelYourSite – Your smart PIXEL (TAG) Manager pixelyoursite allows Stored XSS.This issue affects...
Data exposure
Information meant to stay private could be read.
Score 7.5 (high)no login neededAffected: older than 9.7.2Fixed in 9.7.2Published 3 September 2024CVE-2024-7870
Advisory: The PixelYourSite – Your smart PIXEL (TAG) & API Manager and the PixelYourSite PRO plugins for WordPress are vulnerable to Sensitive Information Exposure in all versions up to, and including, 9.7.1 and 10.4.2,...
How to check your version
- Log in to WordPress and open
Plugins > Installed Plugins. - Find PixelYourSite. The version number is under its name. If it is lower than 11.2.0.2, your store is affected.
- No login to hand? Open
https://yourstore.com/wp-content/plugins/pixelyoursite/readme.txtin a browser, with your own address in place of yourstore.com, and read theStable tagline. Some hosts block this file; then use step 1.
How to fix it
- Make a backup, or better, a staging copy of the store (most hosts have a one-click staging button).
- On the copy, update PixelYourSite to 11.2.0.2 or newer:
Dashboard > Updates, orUpdate nowon the Plugins page. - If no update shows, it may be a paid version whose licence has run out: download the new version from the seller's site and upload it.
- Place a test order on the copy: add to cart, check out, pay with a test method. Check the pages that use PixelYourSite.
- If everything works, make the same update on the live store and place one more test order.
- If you no longer use PixelYourSite, delete it instead of leaving it deactivated.
Not sure, or no time?
Get a free check of your store: we look at its public pages for plugins with known holes, and reply within one working day. Or we fix it for you: we update your store on a copy, place a test order, and only then change the live store, for a fixed £99 / $119.
Free store check Fix it for me on a copyQuestions
- Which PixelYourSite version fixes it?
- Version 11.2.0.2 or newer fixes all 2 issues on this page.
- How do I know if my store is affected?
- Your store is affected if it runs PixelYourSite older than 11.2.0.2. In WordPress, open Plugins and read the version under PixelYourSite. Without logging in, open yourstore.com/wp-content/plugins/pixelyoursite/readme.txt and read the Stable tag line.
- I don't use PixelYourSite any more. Is a deactivated copy safe?
- Deactivating it lowers the risk but leaves the old code on your server. If you don't use it, delete it; if you do, update it.
- Can someone fix it for me?
- Yes. We update the store on a copy first, place a test order, and only then make the same change on the live store, for a fixed price.
Vulnerability data: WPVulnerability (wpvulnerability.net, CC0), which links each entry to its CVE or advisory. Store numbers: Tadrik's own checks of public pages, aggregates only. Page updated 3 November 2026.