tadrik Free store check

Plugin security / Newsletter

Newsletter vulnerability: is your WooCommerce store affected?

Newsletter has 3 serious security holes rated 7 or higher out of 10 that someone can use with no login or with only a customer account. The newest was published on 30 September 2026. Every one is fixed: update to 9.4.1 or newer.

Short answer: your store is affected if it runs Newsletter older than 9.4.1. Update to 9.4.1 or newer, on a copy of the store first if you can.

In our check of 3,600 live UK and US WooCommerce stores (31 October 2026 to 1 November 2026), 9 were running a version of Newsletter with a serious hole that already had a fix. How we checked.

The security holes

Newest first. Each one is published in a public security database and fixed in the version shown.

  1. Cross-site scripting

    Someone could plant a script that runs in your visitors' or your admins' browsers.

    Score 7.2 (high)no login neededAffected: older than 9.4.1Fixed in 9.4.1Published 30 September 2026CVE-2026-96566

    Advisory: The Newsletter – Send awesome emails from WordPress plugin for WordPress is vulnerable to Stored Cross-Site Scripting via 'np1' Custom Field Parameter in all versions up to, and including, 9.4.0 due to insufficient...

  2. Cross-site scripting

    Someone could plant a script that runs in your visitors' or your admins' browsers.

    Score 7.1 (high)no login neededAffected: older than 9.3.4Fixed in 9.3.4Published 19 August 2026CVE-2026-66596

    Advisory: Unauthenticated Cross Site Scripting (XSS) in Newsletter <= 9.3.3 versions.

1 older hole, published before 1 January 2023
  1. PHP object injection

    In some setups, someone could make your server run code.

    Score 8.8 (high)needs only a customer accountAffected: older than 6.8.2Fixed in 6.8.2Published 2 August 2020CVE-2020-35932

    Advisory: Insecure Deserialization in the Newsletter plugin before 6.8.2 for WordPress allows authenticated remote attackers with minimal privileges (such as subscribers) to use the tpnc_render AJAX action to inject arbitrary...

How to check your version

  1. Log in to WordPress and open Plugins > Installed Plugins.
  2. Find Newsletter. The version number is under its name. If it is lower than 9.4.1, your store is affected.
  3. No login to hand? Open https://yourstore.com/wp-content/plugins/newsletter/readme.txt in a browser, with your own address in place of yourstore.com, and read the Stable tag line. Some hosts block this file; then use step 1.

How to fix it

  1. Make a backup, or better, a staging copy of the store (most hosts have a one-click staging button).
  2. On the copy, update Newsletter to 9.4.1 or newer: Dashboard > Updates, or Update now on the Plugins page.
  3. If no update shows, it may be a paid version whose licence has run out: download the new version from the seller's site and upload it.
  4. Place a test order on the copy: add to cart, check out, pay with a test method. Check the pages that use Newsletter.
  5. If everything works, make the same update on the live store and place one more test order.
  6. If you no longer use Newsletter, delete it instead of leaving it deactivated.

Not sure, or no time?

Get a free check of your store: we look at its public pages for plugins with known holes, and reply within one working day. Or we fix it for you: we update your store on a copy, place a test order, and only then change the live store, for a fixed £99 / $119.

Free store check Fix it for me on a copy

Questions

Which Newsletter version fixes it?
Version 9.4.1 or newer fixes all 3 issues on this page.
How do I know if my store is affected?
Your store is affected if it runs Newsletter older than 9.4.1. In WordPress, open Plugins and read the version under Newsletter. Without logging in, open yourstore.com/wp-content/plugins/newsletter/readme.txt and read the Stable tag line.
I don't use Newsletter any more. Is a deactivated copy safe?
Deactivating it lowers the risk but leaves the old code on your server. If you don't use it, delete it; if you do, update it.
Can someone fix it for me?
Yes. We update the store on a copy first, place a test order, and only then make the same change on the live store, for a fixed price.

Vulnerability data: WPVulnerability (wpvulnerability.net, CC0), which links each entry to its CVE or advisory. Store numbers: Tadrik's own checks of public pages, aggregates only. Page updated 3 November 2026.