Plugin security / Kadence Blocks
Kadence Blocks vulnerability: is your WooCommerce store affected?
Kadence Blocks has 2 serious security holes rated 7 or higher out of 10 that someone can use with no login or with only a customer account. The newest was published on 4 October 2026. Every one is fixed: update to 3.7.12 or newer.
Short answer: your store is affected if it runs Kadence Blocks older than 3.7.12. Update to 3.7.12 or newer, on a copy of the store first if you can.
In our check of 3,600 live UK and US WooCommerce stores (31 October 2026 to 1 November 2026), 6 were running a version of Kadence Blocks with a serious hole that already had a fix. How we checked.
The security holes
Newest first. Each one is published in a public security database and fixed in the version shown.
Cross-site scripting
Someone could plant a script that runs in your visitors' or your admins' browsers.
Score 7.1 (high)no login neededAffected: older than 3.7.12Fixed in 3.7.12Published 4 October 2026CVE-2026-103354
Advisory: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Liquid Web / StellarWP Gutenberg Blocks by Kadence Blocks kadence-blocks allows Stored XSS.This issue affects...
Server-side request forgery
Someone could make your server send requests on their behalf.
Score 7.7 (high)needs only a customer accountAffected: older than 3.2.20Fixed in 3.2.20Published 26 March 2024CVE-2024-23500
Advisory: Server-Side Request Forgery (SSRF) vulnerability in StellarWP Gutenberg Blocks by Kadence Blocks kadence-blocks.This issue affects Gutenberg Blocks by Kadence Blocks: from n/a through <= 3.2.19.
How to check your version
- Log in to WordPress and open
Plugins > Installed Plugins. - Find Kadence Blocks. The version number is under its name. If it is lower than 3.7.12, your store is affected.
- No login to hand? Open
https://yourstore.com/wp-content/plugins/kadence-blocks/readme.txtin a browser, with your own address in place of yourstore.com, and read theStable tagline. Some hosts block this file; then use step 1.
How to fix it
- Make a backup, or better, a staging copy of the store (most hosts have a one-click staging button).
- On the copy, update Kadence Blocks to 3.7.12 or newer:
Dashboard > Updates, orUpdate nowon the Plugins page. - If no update shows, it may be a paid version whose licence has run out: download the new version from the seller's site and upload it.
- Place a test order on the copy: add to cart, check out, pay with a test method. Check the pages that use Kadence Blocks.
- If everything works, make the same update on the live store and place one more test order.
- If you no longer use Kadence Blocks, delete it instead of leaving it deactivated.
Not sure, or no time?
Get a free check of your store: we look at its public pages for plugins with known holes, and reply within one working day. Or we fix it for you: we update your store on a copy, place a test order, and only then change the live store, for a fixed £99 / $119.
Free store check Fix it for me on a copyQuestions
- Which Kadence Blocks version fixes it?
- Version 3.7.12 or newer fixes all 2 issues on this page.
- How do I know if my store is affected?
- Your store is affected if it runs Kadence Blocks older than 3.7.12. In WordPress, open Plugins and read the version under Kadence Blocks. Without logging in, open yourstore.com/wp-content/plugins/kadence-blocks/readme.txt and read the Stable tag line.
- I don't use Kadence Blocks any more. Is a deactivated copy safe?
- Deactivating it lowers the risk but leaves the old code on your server. If you don't use it, delete it; if you do, update it.
- Can someone fix it for me?
- Yes. We update the store on a copy first, place a test order, and only then make the same change on the live store, for a fixed price.
Vulnerability data: WPVulnerability (wpvulnerability.net, CC0), which links each entry to its CVE or advisory. Store numbers: Tadrik's own checks of public pages, aggregates only. Page updated 3 November 2026.