tadrik Free store check

Plugin security / Elementor

Elementor vulnerability: is your WooCommerce store affected?

Elementor has 6 serious security holes rated 7 or higher out of 10 that someone can use with no login or with only a customer account. The newest was published on 29 June 2026. Every one is fixed: update to 4.3.2 or newer.

Short answer: your store is affected if it runs Elementor older than 4.3.2. Update to 4.3.2 or newer, on a copy of the store first if you can.

In our check of 3,600 live UK and US WooCommerce stores (31 October 2026 to 1 November 2026), 65 were running a version of Elementor with a serious hole that already had a fix. How we checked.

The security holes

Newest first. Each one is published in a public security database and fixed in the version shown.

  1. Cross-site request forgery

    Someone could trick a logged-in admin into making a change.

    Score 8.8 (high)no login neededAffected: 4.3.0 up to, not including, 4.3.2Fixed in 4.3.2Published 29 June 2026CVE-2026-62062

    Advisory: Cross-Site Request Forgery (CSRF) vulnerability in Elementor Website Builder allows Cross Site Request Forgery.

  2. File access

    Someone could read files on your server they should never see.

    Score 8.5 (high)needs only a customer accountAffected: older than 3.19.1Fixed in 3.19.1Published 7 February 2024CVE-2024-24934

    Advisory: Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in Elementor Elementor Website Builder allows Manipulating Web Input to File System Calls.This issue affects Elementor...

  3. File upload

    Someone could upload files to your server, which can include code.

    Score 9.9 (critical)needs only a customer accountAffected: older than 3.18.2Fixed in 3.18.2Published 6 December 2023CVE-2023-48777

    Advisory: Unrestricted Upload of File with Dangerous Type vulnerability in Elementor.Com Elementor Website Builder.This issue affects Elementor Website Builder: from 3.3.0 through 3.18.1.

3 older holes, published before 1 January 2023
  1. Cross-site scripting

    Someone could plant a script that runs in your visitors' or your admins' browsers.

    Score 9.8 (critical)no login neededAffected: older than 2.8.4Fixed in 2.8.4Published 19 January 2020CVE-2020-7109

    Advisory: The Elementor Page Builder plugin before 2.8.4 for WordPress does not sanitize data during creation of a new template.

  2. File upload

    Someone could upload files to your server, which can include code.

    Score 9.9 (critical)needs only a customer accountAffected: older than 2.7.5Fixed in 2.7.5Published 28 October 2019CVE-2020-7055

    Advisory: An issue was discovered in Elementor 2.7.4.

  3. Missing permission check

    An action that should need permission could be done without it.

    Score 8.8 (high)needs only a customer accountAffected: older than 1.8.0Fixed in 1.8.0Published 27 November 2017CVE-2017-18596

    Advisory: The elementor plugin before 1.8.0 for WordPress has incorrect access control for internal functions.

How to check your version

  1. Log in to WordPress and open Plugins > Installed Plugins.
  2. Find Elementor. The version number is under its name. If it is lower than 4.3.2, your store is affected.
  3. No login to hand? Open https://yourstore.com/wp-content/plugins/elementor/readme.txt in a browser, with your own address in place of yourstore.com, and read the Stable tag line. Some hosts block this file; then use step 1.

How to fix it

  1. Make a backup, or better, a staging copy of the store (most hosts have a one-click staging button).
  2. On the copy, update Elementor to 4.3.2 or newer: Dashboard > Updates, or Update now on the Plugins page.
  3. If no update shows, it may be a paid version whose licence has run out: download the new version from the seller's site and upload it.
  4. Place a test order on the copy: add to cart, check out, pay with a test method. Check the pages that use Elementor.
  5. If everything works, make the same update on the live store and place one more test order.
  6. If you no longer use Elementor, delete it instead of leaving it deactivated.

Not sure, or no time?

Get a free check of your store: we look at its public pages for plugins with known holes, and reply within one working day. Or we fix it for you: we update your store on a copy, place a test order, and only then change the live store, for a fixed £99 / $119.

Free store check Fix it for me on a copy

Questions

Which Elementor version fixes it?
Version 4.3.2 or newer fixes all 6 issues on this page.
How do I know if my store is affected?
Your store is affected if it runs Elementor older than 4.3.2. In WordPress, open Plugins and read the version under Elementor. Without logging in, open yourstore.com/wp-content/plugins/elementor/readme.txt and read the Stable tag line.
I don't use Elementor any more. Is a deactivated copy safe?
Deactivating it lowers the risk but leaves the old code on your server. If you don't use it, delete it; if you do, update it.
Can someone fix it for me?
Yes. We update the store on a copy first, place a test order, and only then make the same change on the live store, for a fixed price.

Vulnerability data: WPVulnerability (wpvulnerability.net, CC0), which links each entry to its CVE or advisory. Store numbers: Tadrik's own checks of public pages, aggregates only. Page updated 3 November 2026.