Plugin security / GTM4WP (Google Tag Manager for WordPress)
GTM4WP (Google Tag Manager for WordPress) vulnerability: is your WooCommerce store affected?
GTM4WP (Google Tag Manager for WordPress) has one serious security hole rated 7 or higher out of 10 that someone can use with no login or with only a customer account. The newest was published on 28 July 2026. Every one is fixed: update to 1.22.4 or newer.
Short answer: your store is affected if it runs GTM4WP (Google Tag Manager for WordPress) older than 1.22.4. Update to 1.22.4 or newer, on a copy of the store first if you can.
In our check of 3,600 live UK and US WooCommerce stores (31 October 2026 to 1 November 2026), 32 were running a version of GTM4WP (Google Tag Manager for WordPress) with a serious hole that already had a fix. How we checked.
The security holes
Newest first. Each one is published in a public security database and fixed in the version shown.
Cross-site scripting
Someone could plant a script that runs in your visitors' or your admins' browsers.
Score 7.2 (high)no login neededAffected: older than 1.22.4Fixed in 1.22.4Published 28 July 2026CVE-2026-16597
Advisory: The GTM4WP – A Google Tag Manager (GTM) plugin for WordPress plugin for WordPress is vulnerable to Stored Cross-Site Scripting via WooCommerce Billing Fields in all versions up to, and including, 1.22.3 due to...
How to check your version
- Log in to WordPress and open
Plugins > Installed Plugins. - Find GTM4WP (Google Tag Manager for WordPress). The version number is under its name. If it is lower than 1.22.4, your store is affected.
- No login to hand? Open
https://yourstore.com/wp-content/plugins/duracelltomi-google-tag-manager/readme.txtin a browser, with your own address in place of yourstore.com, and read theStable tagline. Some hosts block this file; then use step 1.
How to fix it
- Make a backup, or better, a staging copy of the store (most hosts have a one-click staging button).
- On the copy, update GTM4WP (Google Tag Manager for WordPress) to 1.22.4 or newer:
Dashboard > Updates, orUpdate nowon the Plugins page. - If no update shows, it may be a paid version whose licence has run out: download the new version from the seller's site and upload it.
- Place a test order on the copy: add to cart, check out, pay with a test method. Check the pages that use GTM4WP (Google Tag Manager for WordPress).
- If everything works, make the same update on the live store and place one more test order.
- If you no longer use GTM4WP (Google Tag Manager for WordPress), delete it instead of leaving it deactivated.
Not sure, or no time?
Get a free check of your store: we look at its public pages for plugins with known holes, and reply within one working day. Or we fix it for you: we update your store on a copy, place a test order, and only then change the live store, for a fixed £99 / $119.
Free store check Fix it for me on a copyQuestions
- Which GTM4WP (Google Tag Manager for WordPress) version fixes it?
- Version 1.22.4 or newer fixes the issue on this page.
- How do I know if my store is affected?
- Your store is affected if it runs GTM4WP (Google Tag Manager for WordPress) older than 1.22.4. In WordPress, open Plugins and read the version under GTM4WP (Google Tag Manager for WordPress). Without logging in, open yourstore.com/wp-content/plugins/duracelltomi-google-tag-manager/readme.txt and read the Stable tag line.
- I don't use GTM4WP (Google Tag Manager for WordPress) any more. Is a deactivated copy safe?
- Deactivating it lowers the risk but leaves the old code on your server. If you don't use it, delete it; if you do, update it.
- Can someone fix it for me?
- Yes. We update the store on a copy first, place a test order, and only then make the same change on the live store, for a fixed price.
Vulnerability data: WPVulnerability (wpvulnerability.net, CC0), which links each entry to its CVE or advisory. Store numbers: Tadrik's own checks of public pages, aggregates only. Page updated 3 November 2026.