tadrik Free store check

Plugin security / Starter Templates

Starter Templates vulnerability: is your WooCommerce store affected?

Starter Templates has 3 serious security holes rated 7 or higher out of 10 that someone can use with no login or with only a customer account. The newest was published on 5 December 2025. Every one is fixed: update to 4.4.42 or newer.

Short answer: your store is affected if it runs Starter Templates older than 4.4.42. Update to 4.4.42 or newer, on a copy of the store first if you can.

In our check of 3,600 live UK and US WooCommerce stores (31 October 2026 to 1 November 2026), 6 were running a version of Starter Templates with a serious hole that already had a fix. How we checked.

The security holes

Newest first. Each one is published in a public security database and fixed in the version shown.

  1. File upload

    Someone could upload files to your server, which can include code.

    Score 8.8 (high)needs only a customer accountAffected: older than 4.4.42Fixed in 4.4.42Published 5 December 2025CVE-2025-13065

    Advisory: The Starter Templates plugin for WordPress is vulnerable to arbitrary file upload in all versions up to, and including, 4.4.41.

  2. Server-side request forgery

    Someone could make your server send requests on their behalf.

    Score 7.1 (high)needs only a customer accountAffected: older than 3.2.5Fixed in 3.2.5Published 28 March 2024CVE-2023-34370

    Advisory: Server-Side Request Forgery (SSRF) vulnerability in Brainstorm Force Starter Templates — Elementor, WordPress & Beaver Builder Templates, Brainstorm Force Premium Starter Templates.This issue affects Starter...

  3. Server-side request forgery

    Someone could make your server send requests on their behalf.

    Score 7.1 (high)needs only a customer accountAffected: older than 3.2.5Fixed in 3.2.5Published 5 September 2023CVE-2023-41804

    Advisory: Server-Side Request Forgery (SSRF) vulnerability in Brainstorm Force Starter Templates — Elementor, WordPress & Beaver Builder Templates.This issue affects Starter Templates — Elementor, WordPress & Beaver Builder...

How to check your version

  1. Log in to WordPress and open Plugins > Installed Plugins.
  2. Find Starter Templates. The version number is under its name. If it is lower than 4.4.42, your store is affected.
  3. No login to hand? Open https://yourstore.com/wp-content/plugins/astra-sites/readme.txt in a browser, with your own address in place of yourstore.com, and read the Stable tag line. Some hosts block this file; then use step 1.

How to fix it

  1. Make a backup, or better, a staging copy of the store (most hosts have a one-click staging button).
  2. On the copy, update Starter Templates to 4.4.42 or newer: Dashboard > Updates, or Update now on the Plugins page.
  3. If no update shows, it may be a paid version whose licence has run out: download the new version from the seller's site and upload it.
  4. Place a test order on the copy: add to cart, check out, pay with a test method. Check the pages that use Starter Templates.
  5. If everything works, make the same update on the live store and place one more test order.
  6. If you no longer use Starter Templates, delete it instead of leaving it deactivated.

Not sure, or no time?

Get a free check of your store: we look at its public pages for plugins with known holes, and reply within one working day. Or we fix it for you: we update your store on a copy, place a test order, and only then change the live store, for a fixed £99 / $119.

Free store check Fix it for me on a copy

Questions

Which Starter Templates version fixes it?
Version 4.4.42 or newer fixes all 3 issues on this page.
How do I know if my store is affected?
Your store is affected if it runs Starter Templates older than 4.4.42. In WordPress, open Plugins and read the version under Starter Templates. Without logging in, open yourstore.com/wp-content/plugins/astra-sites/readme.txt and read the Stable tag line.
I don't use Starter Templates any more. Is a deactivated copy safe?
Deactivating it lowers the risk but leaves the old code on your server. If you don't use it, delete it; if you do, update it.
Can someone fix it for me?
Yes. We update the store on a copy first, place a test order, and only then make the same change on the live store, for a fixed price.

Vulnerability data: WPVulnerability (wpvulnerability.net, CC0), which links each entry to its CVE or advisory. Store numbers: Tadrik's own checks of public pages, aggregates only. Page updated 3 November 2026.