Plugin security / Advanced Product Fields (Product Addons) for WooCommerce
Advanced Product Fields (Product Addons) for WooCommerce vulnerability: is your WooCommerce store affected?
Advanced Product Fields (Product Addons) for WooCommerce has one serious security hole rated 7 or higher out of 10 that someone can use with no login or with only a customer account. The newest was published on 20 April 2026. Every one is fixed: update to 1.6.22 or newer.
Short answer: your store is affected if it runs Advanced Product Fields (Product Addons) for WooCommerce older than 1.6.22. Update to 1.6.22 or newer, on a copy of the store first if you can.
In our check of 3,600 live UK and US WooCommerce stores (31 October 2026 to 1 November 2026), 6 were running a version of Advanced Product Fields (Product Addons) for WooCommerce with a serious hole that already had a fix. How we checked.
The security holes
Newest first. Each one is published in a public security database and fixed in the version shown.
Security issue
Score 7.5 (high)no login neededAffected: older than 1.6.22Fixed in 1.6.22Published 20 April 2026CVE-2026-2996
Advisory: The Advanced Product Fields (Product Addons) for WooCommerce plugin for WordPress is vulnerable to Improper Input Validation in all versions up to, and including, 1.6.21.
How to check your version
- Log in to WordPress and open
Plugins > Installed Plugins. - Find Advanced Product Fields (Product Addons) for WooCommerce. The version number is under its name. If it is lower than 1.6.22, your store is affected.
- No login to hand? Open
https://yourstore.com/wp-content/plugins/advanced-product-fields-for-woocommerce/readme.txtin a browser, with your own address in place of yourstore.com, and read theStable tagline. Some hosts block this file; then use step 1.
How to fix it
- Make a backup, or better, a staging copy of the store (most hosts have a one-click staging button).
- On the copy, update Advanced Product Fields (Product Addons) for WooCommerce to 1.6.22 or newer:
Dashboard > Updates, orUpdate nowon the Plugins page. - If no update shows, it may be a paid version whose licence has run out: download the new version from the seller's site and upload it.
- Place a test order on the copy: add to cart, check out, pay with a test method. Check the pages that use Advanced Product Fields (Product Addons) for WooCommerce.
- If everything works, make the same update on the live store and place one more test order.
- If you no longer use Advanced Product Fields (Product Addons) for WooCommerce, delete it instead of leaving it deactivated.
Not sure, or no time?
Get a free check of your store: we look at its public pages for plugins with known holes, and reply within one working day. Or we fix it for you: we update your store on a copy, place a test order, and only then change the live store, for a fixed £99 / $119.
Free store check Fix it for me on a copyQuestions
- Which Advanced Product Fields (Product Addons) for WooCommerce version fixes it?
- Version 1.6.22 or newer fixes the issue on this page.
- How do I know if my store is affected?
- Your store is affected if it runs Advanced Product Fields (Product Addons) for WooCommerce older than 1.6.22. In WordPress, open Plugins and read the version under Advanced Product Fields (Product Addons) for WooCommerce. Without logging in, open yourstore.com/wp-content/plugins/advanced-product-fields-for-woocommerce/readme.txt and read the Stable tag line.
- I don't use Advanced Product Fields (Product Addons) for WooCommerce any more. Is a deactivated copy safe?
- Deactivating it lowers the risk but leaves the old code on your server. If you don't use it, delete it; if you do, update it.
- Can someone fix it for me?
- Yes. We update the store on a copy first, place a test order, and only then make the same change on the live store, for a fixed price.
Vulnerability data: WPVulnerability (wpvulnerability.net, CC0), which links each entry to its CVE or advisory. Store numbers: Tadrik's own checks of public pages, aggregates only. Page updated 3 November 2026.